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Users
When you choose Users from the View menu, RightFAX will show you a list of all the users 
currently registered with RightFAX.    It will include their user IDs, names, routing codes (if 
you use DID, DTMF, or Channel routing), and how many faxes they have.

 

To edit a user, highlight the line containing the ID and double click on it or choose Edit from 
the Edit menu.

Creating Users
Importing Users
Editing Users
Deleting Users



Groups
When you choose Groups from the View menu, RightFAX will show you a list of all the 
different groups of users, including their administrators, alternate administrators, and what 
cover sheet is assigned to each group.

To edit a group, double click on it, or select it with the mouse and choose Edit from the Edit 
menu.

Creating Groups
Editing Groups
Deleting Groups



Signatures
When you choose Signatures from the View menu, RightFAX shows you a list of all the 
signatures registered with RightFAX, including the signature code ID, the user ID, a 
description of the signature, and who is authorized to use it.

Creating Signatures
Editing Signatures
Deleting Signatures



Forms
When you choose Forms from the View menu, RightFAX shows you a list of all the forms 
associated with your system.    A form is a special document that has already been converted
into a fax format, and can be used as an overlay for other documents.    You could, for 
example, create forms for company letterhead paper, fill-in purchase orders, etc.

Creating Forms
Editing Forms
Deleting Forms



Printers
When you choose Printers from the View menu, FaxAdmin displays all the printers that are 
defined in RightFAX.    If RightFAX does not display any printers you will need to create or 
import some before you can print.    Do not include your fax queues as printers; as this would
fax your fax...

Creating Printers
Importing Printers
Editing Printers
Deleting Printers



Billing Codes
Choosing Billing Codes from the View menu displays all the billing codes defined for your 
company.    These are codes that users may enter on their Fax Information screens.    The fax 
server will keep records of faxes (assuming Auto-Purge is not enabled) and corresponding 
billing codes for use in cost recovery, cost tracking, fax tracking, etc.    You can require users 
to enter billing codes for all faxes that they send and/or receive.    You can also Validate the 
codes, so users have to enter "correct" codes.

Creating Billing Codes
Importing Billing Codes
Editing Billing Codes
Deleting Billing Codes
Required Fields



Library
Choosing Library from the View menu in FaxAdmin displays all the library documents 
developed for your RightFAX system.    A library document is a document which is faxed 
frequently by company employees; it is already converted to a Group III format so that 
RightFAX does not have to execute a lengthy conversion redundantly.    Credit applications, 
company information, product information, etc. are all examples of possible library 
documents.

Creating Library Documents
Editing Library Documents
Deleting Library Documents



Create User
To Create a user you can either press the Insert key or choose New from the Edit    while 
the User List is displayed.    The Edit User dialog box appeares with a "blank" user.    Newly 
created users inherit their attributes from the Default user record. 

 
Note: You may click on the various sections in the window above for more information.

See Also:
Editing Users
Importing Users



Importing Users
This feature will import users from a specified file server or Organizational Unit (OU).    It is 
found under the Edit menu while in the User View.    New users created during the import 
will inherit the attributes of the DEFAULT user.    You may repeat this process for any number 
of file servers or OUs.    You may use the Import All button to import all users from a server 
or OU at once.

 
Note: You may click on the various sections in the window above for more information.

Note: Under Novell 4.x you must be at a PC running VLM to use Network Directory Services 
(NDS) for importing.    If you are at a PC running NETX users will be imported from the 
Bindery.    Under LAN Server and Windows NT networks FaxAdmin will import from the 
Primary Domain Controller.



Edit Users
Select the user you wish to edit, from the User View, and either double click on it with the 
mouse or press enter, and an Edit User dialog box will appear, similar to the one below.

 
Note: You may click on the various sections in the window above for more information.

See also:
Creating Users
Importing Users



Deleting Users
To delete a user select the user and press the Delete key or pulldown the Edit menu and 
choose Delete.    You may select multiple Users to delete.    If a user owns faxes or 
phonebook entries, you will be prompted to verify that all the faxes and/or phonebook 
entries be erased.    There is no way to recover users, or the faxes and/or phonebook entries 
they owned, after the user is deleted.



Creating Groups
While in the Group View select New from the Edit menu. 

 
Note: You may click on the various sections in the window above for more information.

See Also:
Editing Groups



Editing Groups
Select the group you wish to edit and either double click on it or select Edit from the Edit 
menu.

 
Note: You may click on the various sections in the window above for more information.

See also:
Creating Groups



Deleting Groups
To delete a group; select the group and chose Delete from the Edit menu or press the 
Delete key.    Deleting a Group does NOT delete the users belonging to the group.    
However, all users belonging to the group must have their group reassigned by editing the 
user records.    Notifications, automatic purging, and coversheet selection may all exhibit 
strange behavior if the group to which a user belongs is deleted and the user is not assigned
to a new group.



Creating Signatures
To personalize outgoing faxes, RightFAX offers users the ability to add their own signatures 
to documents destined for transmission.    Signatures are stored as graphic images in the \
RIGHTFAX\SIG directory.

To create a signature , either fax yourself a copy of your signature, or scan your signature 
into RightFAX as a new fax.    (In FaxUtil press Insert to create a new fax, then from the Fax 
Information window, press the Scan button to scan your signature.)

View the received or scanned fax, and choose the Select box from the Box View Toolbar.    
(The Select box is a clear rectangle with dotted edges.)    With the mouse, select your 
signature, and choose Make Signature from the Edit menu in the Fax Viewer.

You will be presented with an Edit Signature box to complete.    Designate a Signature Code, 
User ID, and Description for this signature.    You will also need to specify which users, by ID, 
can use this signature in their faxes.    Note that the owner of the signature is not implicitly 
authorized to use it, so be sure to include his or her user ID in one of the Authorized Users 
fields.

Note:    Only users with RightFAX administrative privileges are allowed to create Signatures 
from within the Windows Fax Viewer.

See also:
Editing Signatures



Editing Signatures
You may edit a signature by double clicking on it or by selecting it and choosing Edit from 
the Edit menu.    A window like the one below appears.    You are not allowed to modify the 
actual signature image.    In order to change the signature image, simply recreate a 
signature with the same ID from within the Windows Fax Viewer.

 
Note: You may click on the various sections in the window above for more information.

See also:
Creating Signatures



Deleting Signatures
If you wish to delete a signature select the signature and press the Delete key or choose 
Delete from the Edit menu.    The signature image file (found in \RIGHTFAX\SIG) is not 
removed when the signature object is deleted.    Therefore, you may wish to remove a 
signature object's image file prior to deleting the object.



Creating Forms
A form type is an overlay that will make your outgoing faxes look as if they were printed on 
letterhead, preprinted forms, or just about anything else.    A form can be as simple or 
complex as necessary to fulfill your needs.    To create a form, place a sheet of paper 
containing the desired image (e.g. a letterhead) into an HP ScanJet or compatible scanner, 
and in the DOS version of FaxUtil, while in the Form View, choose New from the Edit menu 
(or press insert) to bring up a dialog box like the one shown below.
 

 
Note: You may click on the various sections in the window above for more information.

Once you have entered all of the appropriate information, use the alt-s key combination to 
begin scanning.    The form will be scanned twice; once in fine (high resolution) mode and 
once in regular mode, which are analogous to detailed and standard modes on a fax 
machine.

To create a form without a scanner, fax a sheet of paper with the form design on it to your 
RightFAX fax mailbox.    You will need to fax the same form twice - once in Normal mode and 
once in Fine mode.    From the DOS or OS/2 version of RightFAX, highlight the Fine mode fax,
and select Export Image from the Fax menu.    You will be prompted to choose a format in 
which to save the image; choose Group III formatting.    In specifying where to save the fax 
image, type \rightfax\papers\form2 with no extension.    Next, highlight the Normal mode 
fax, and select Export Image from the Fax menu.    You will be prompted to choose a format
in which to save the image; choose Group III formatting.    In specifying where to save the 
fax image, type \rightfax\papers\form1 with no extension.    

After exporting both images, exit to a DOS or OS/2 command prompt, switch into the \
Rightfax\Papers directory and rename the two form images you just exported (replace 
myform with an 8 character maximum file name):

J:\RIGHTFAX\PAPERS> ren form1 myform.301 J:\RIGHTFAX\PAPERS> ren form2 
myform.302
 
Alternatively, Windows users can highlight the Fine mode fax, view it with the Fax Viewer, 
and choose Save As from the File menu.    Save this fax as form2 as above, then do the 
same for the Normal mode form1.

When finished, switch to FaxAdmin, and View the Forms section.    Press Insert to define 
your new form, and complete the fields as usual.    Note that in the field entitled Image 
Filename, you will have to specify the name of the form that you just exported into the \
papers directory.    It is not necessary to enter the file's path name because RightFAX will 
automatically search the \papers directory for your file.

Example 1: If you wish to create a form for your company letterhead that appears on 
every page of the document, you need to complete the Form Code and the Starting Page.    



The Form Code could be called Letterhd, for instance, the Starting Page would be 1, and 
the Number of Pages would be zero or blank, because you want the form to appear on all 
pages of the fax, and RightFAX automatically assumes that if the Number of Pages field is 
zero or blank, the form is to appear on all pages.

Example 2: If your first page has a large company masthead while the rest of the pages 
are smaller versions of the masthead, you need to create two different forms; one for the 
first page and one for the following pages.    The first page would have a Starting Page of 1, 
a Number of Pages of 1, and a Next Type ID Number of the smaller version's form number.    
The smaller version needs a Starting Page of 2, and a blank for the Number of Pages.    Its 
Next Type field would be set to 0, to indicate that it is the last form in the chain.

Note: The page numbers you specify in the Start Page field are absolute.    If the Start Page 
for a form is set to three and you apply it to a document which only has two pages, 
none of the document pages will be overlaid.

See also:
Editing Forms



Editing Forms
To edit a form go to the Form View, select the from with the mouse and choose Edit under 
the Edit menu.    A window will appear like the one below.

 
Note: You may click on the various sections in the window above for more information.

See also:
Creating Forms



Deleting Forms
To delete a Form go to the Form View, select the desired Form and press the Delete key or 
choose Delete from the Edit menu.    Deleting a Form does not remove the form image 
file(s) from the \RIGHTFAX\PAPERS directory.



Importing Printers
Go to the Printer View and choose Import Data from the Edit menu.    A new window will 
appear which asks what server you would like to import printers from.    You may select one 
or more printers by using the mouse together with the Shift key and/or the Ctrl key.    Then 
click on the Import Selected button to import only selected printers.

 

Note: It does not make sense to import the print queues which the RightFAX server is 
servicing as outgoing fax queues.    In the above example, the HPFAX, FAX2, and FAXTEXT 
queues are outbound fax queues to which users direct output in order that they send faxes.   
It, therefore, does not make sense to be able to print a received fax to an outbound fax 
queue (if users want to forward a received fax to another fax machine, there is a specific 
function for doing so from within the FaxUtil).



Creating Printers
While in the printer View select NEW from the Edit menu.    A window will appear like the 
one below.

 
Note: You may click on the various sections in the window above for more information.

See also:
Editing Printers
Importing Printers



Editing Printers
To Edit a printer select the printer and choose EDIT from the Edit menu.    A window like the 
one below will appear.

 
Note: You may click on the various sections in the window above for more information.

See also:
Creating Printers
Importing Printers



Deleting Printers
Enter the Printer View and select the printer you wish to delete press the Delete key or 
choose Delete from Edit menu.    Any queued requests by users to print a fax, or faxes, on 
the queue being deleted will result in printing failures, i.e. because there will be no printer 
object to which to print.



Creating Billing Codes
Enter the Billing Code View and select New from the Edit menu.    A new window will appear 
similar to the one below.

 
Note: You may click on the various sections in the window above for more information.

The labels you see above (Account and Matter Number) may differ as these are definable 
using Customize FCS menu option. 
See also:

Editing Billing Codes
Importing Billing Codes
Automatic Billing Code Importing



Importing Billing Codes
The RightFAX database can maintain detailed information about fax transmissions for 
reporting and billing purposes.    Users can be required to enter one or two billing codes into 
the fax record before it is sent or deleted.    Each record can hold either one or both of the 
two available billing code fields, and a text description.
 
FaxAdmin can import billing codes from two types of ASCII text files.    WIth both types, the 
files must be formatted with one billing code record per line.    The codes themselves cannot 
contain spaces, but the description may.    The codes and description can be separated by 
spaces, tabs, or commas.    Blank lines are skipped.    

The first type only allows additions to the billing code table (it cannot be used to import 
changes or deletions).    The format is:

BILLINFO1,BILLINFO2,DESCRIPTION
For example:

Acme,4567,Acme Steele, Inc.
Acme,,Acme General Account 
Barnes,1123

The second type allows additions, changes, and deletions to be imported.    It is identical to 
the format use by the Automatic Billing Code Import function.    The second type is 
sometimes referred to as a "delta" format as it only contains changes to the table.    There 
are three types of lines:

A,billinfo1,billinfo2,description
C,billinfo1,billinfo2,description
D,billinfo1,billinfo2

A line starting with 'A' will add a billing code.    A line with 'C' will change a billing code.    A 
line with 'D' deletes the specified billing code.    All lines should terminated with a Carriage-
Return/LineFeed combination and the field values must be seperated with a comma or a tab 
(ASCII 9) character.    There cannot be any comma or tab characters within a BILLINFO1 or 
BILLINFO2 fields, though there can be in the Description data.

See Also:
Automatic Billing Code Importing



Editing Billing Codes
To edit Billing Codes select the billing code you wish to change and select Edit from the Edit
menu.    A window like the one below will show up.

 
Note: You may click on the various sections in the window above for more information.

See also:
Creating Billing Codes
Importing Billing Codes
Automatic Billing Code Importing



Deleting Billing Codes
To delete Billing Codes select the billing code you wish to delete and select Delete from the 
Edit menu.



Creating Library Documents
Library Documents are regularly faxed documents such as product literature, or pricing 
sheets.    You may also use the Library to store records of graphic objects, such as logos, 
which you can embed in your document much the same as a signature.

To create a new library document, you must first create a fax which has the pages you want 
to send.    You can do this by sending the document through the RightFAX print queue, faxing
it to yourself, or using a scanner (or any combination of these methods).    When you have 
the document as you want it to be sent, use the Export function in the DOS FaxUtil program 
to save a copy of the fax images in the Rightfax\Image subdirectory.    If you are using FaxUtil
for Windows, you can use the Save As... option from the Windows Fax Viewer. Save the files
in the Brooktrout Group III format, and remember the filename you enter.
 
In FaxAdmin, change to the Library Document view and press insert to begin a new entry.    A
window like the one below will appear in which you can fill in the required information.    
FaxAdmin will search for the file in the Image directory, count the number of pages, and 
verify that all the pages are the same resolution.

Note: You may click on the various sections in the window above for more information. 

See also:
Edit Library 



Editing Library Documents
Select the Library Document you wish to edit and select Edit from the Edit menu.    A Dialog 
Box Like the one bellow will appear.

 
Note: You may click on the various sections in the window above for more information.

See also:
Creating Library Documents



Deleting Library Documents
To delete a Library Document select the document and press the Delete key or select 
Delete from the Edit menu.    Deleting a Library Document object does not remove the 
images (from \RIGHTFAX\IMAGE) which belonged to the object.    Such images would need to 
be removed manually if they will not be used in another Library Document.



Customizing FCS Fields
Here you may specify what fields are required to be entered in the Fax Information window.

 
Note: You may click on the various sections in the window above for more information.



International Character Support
Enable this option to help convert data from Windows ANSI to DOS code-pages.



Synchronize Document Library
If the optional Ibex LibSync module has been installed, then RightFAX will periodically 
synchronize its document library with that of the Ibex FactsLine Fax-On-Demand system.    
Choosing the Synchronize Document Library function will cause the server to re-synchronize 
ASAP, as opposed to waiting until the next automatic synchronization.



Export Fax Data to DBF
 

  

FaxAdmin allows for the exporting of fax information from the database to a dBase formatted
(.DBF) file.      Before generating the files, select the date range for the data, whether sent, 
received, or both types of faxes should be included, and the level of information to be 
generated.    After these selections have been made, click the Query button to generate the 
data files.    Indices (files with the extension .CDX) will also be generated.    These indices are 
in FoxPro format.    If you use a different xBase system, you can ignore or delete these 
indices.
 
RightFAX includes three preformatted reports that can be previewed on the screen or 
printed.    The reports included are the Fax Summary, the Billing Summary, and the Error Log.
 
The Fax Summary report lists all faxes sorted by user.    This is useful to see if large numbers 
of faxes are collecting in particular users’ boxes.    This report does not list deleted faxes so 
only faxes that still appear in users’ boxes will appear here. Date and time of transmission, 
time to transmit, billing codes and number of pages are displayed in this report.    Total 
pages for each user ID are also displayed.
 
 
The Billing Summary lists all faxes listed by billing code.    They are sorted by both billing 
codes, so all faxes that share a particular first billing code will be further broken out by the 
second billing code.    Unlike the Fax Summary report, faxes that have been deleted will 
appear in this report.    All faxes received during the date range chosen (which will not have 
a billing code) will appear at the top of this report    Date and time of transmission, time to 
transmit, to/from information,    user ID and number of pages are displayed in this report.    
Total pages for each billing code are displayed as well.
 
Finally, the Error Log shows all faxes that were not successfully sent accompanied by the 
error information generated at each attempt.    The user ID of the person who sent the fax is 
showen, along with the date and time, elapsed time and error status of each attempt.    
 
To use these reports, simply select the report to be generated and choose the date range.    



Then click on the Query button to generate the data files for the report.    Finally choose the 
destination for the report and click on the Report button to generate it.    
 
Note: Be aware that the Rescue utility purges all deleted fax records.



Colors
Here you can change the colors used for display in RightFAX.    This item is located under the 
Utility menu.    Selected colors are stored in the WIN.INI file.



Change Password
This Button allows you to change the password for a user.    It is great for users who forget 
their passwords and need to have the administrator change them so they can gain access to
FaxUtil once again.



Routing
Here you specify the type of routing for the user.    i.e. cc:Mail or RightFAX MailBox.    This 
controls to where RightFAX will deliver received faxes.    Routing can automatically, i.e. DID, 
DTMF, OCR, or Line/Channel; manually, where a user executes a File-Route command from 
within FaxUtil; or semi-automatically, where a user executes a File-Forward To Network User 
command from within FaxUtil.

 
Note: You may click on the various sections in the window above for more information.



Administrative Access--This allows users access to the administrative functions of RightFAX.   
Without it a user can not run FaxAdmin nor can a user switch into 
another user's mailbox without the correct password.    If a user does 
not have a password, then any other user can switch into their mailbox
without having Administrative Access.    Group Administrators and 
Alternate Administrators have implicit priviledges to run FaxAdmin for 
and to switch into the mailbox of users belonging to their administered 
group(s).



Archive Sent Faxes -- If enabled, outbound faxes will be archived according to the archive 
options defined in the WorkServer(s).    Configuring the WorkServer(s) is
accomplished using the RightFAX CONFIG utility (OS/2) or the Control 
Panel (NT).

Outbound faxes are archived upon their completion, either successful 
or unsuccessful.    Faxes with a status (ER:xxx), where ER stands for 
Error-Retry, are not archived.    If a fax fails too many times, as defined 
by the FaxRetryCount parameter in the RIGHTFAX.INI, then it's status 
will change to Error-Dropped (ED:xxx).    It is at the point that the fax 
goes to Error-Dropped status that it will be archived.    In this way, a fax
which fails five times in a row will not be archived five times -- only 
once.    If a fax fails and then succeeds on a subsequent retry, it will be 
archived after it succeeds.

Enabling Archive Sent Faxes implicitly disables Automatic 
Deleting of sent faxes (an option controlled by the user from 
within FaxUtil).



Auto-Purge Deleted Faxes -- If Auto-Purge is enabled, then records of faxes deleted by the 
user are not maintained.    When Auto-Purge is disabled, deleted
fax records are maintained for the number of days specified in 
the RightFAX Group to which the user belongs.    If you will be 
running fax or billing reports, it is best to leave Auto-Purge 
disabled (or unchecked), else as the user deletes faxes, auditing
information is deleted as well.

When a user deletes a fax, the fax image is always removed 
from the system irregardless of the Auto-Purge setting.    Since 
the fax images are many times larger than the fax database 
records, space is not a concern.



Bypass Billing Code Verification -- This attribute is only affective if billing code verification 
was previously enabled on a system wide basis.    If so, then 
any user with this attribute enabled will be allowed to send 
faxes without supplying correct billing codes.    This attribute 
will not exclude the user from having to supply "required" 
fields in order to be able to send faxes.

Billing codes are checked against the Billing Code table kept in
the RightFAX database.



Can Change Coversheet -- This allows a user to freely change coversheets.    If you want to 
restrict users to a specific coversheet, remove this attribute by 
unchecking the field.



Can OCR Faxes -- This controls whether or not a user can OCR faxes using RightFAX's 
optional Optical Character Recognition software.    Users initiate the OCR 
process via the FaxUtil program.    This attribute has nothing to do with OCR 
routing and does not have to be enabled if OCR routing is being used.



Can Use High Priority -- This check box controls whether or not a user can send faxes using 
High priority.    Without this attribute enabled, a user is restricted to 
Normal and Low priorities only.    The restriction applies to priorities 
selected from the FaxUtil and through the embedded code 
<PRIORITY:XXX> where XXX can be "HIGH", "NORMAL", or "LOW".

Priorities apply to fax conversions as well as available fax channels.    
Priorities are only available when using Brooktrout fax cards -- they are 
not supported with Gammalink fax cards.



Disallow Fax Deleting -- When enabled, this attribute will prevent a user from deleting faxes. 
It is useful for person(s) doing manual routing.    The restriction applies 
to the user as opposed to the mailbox, so even if the user switches 
mailboxes, they still cannot delete faxes.



Distinguished Name -- This is the Novell name that specifies the users Organizational Unit 
(OU)/Units.    It is the FULL name and tells were this user can be located 
in the NetWare Directory Services (NDS) from any other place in the tree.



FCS Model -- This field sets the default coversheet model for the user (or group).    If a user is
not assigned a specific coversheet model, then the coversheet model assigned 
to the Group to which the user belongs is used.    If the Group is not assigned a 
specific coversheet model, then FCS.PCL is assumed.



Group ID -- Names the Group ID to which this user belongs.    Groups are used for 
coversheet model inheritance, administration, notification method inheritance, 
and more.



Must Have Password -- With this box checked the user MUST have a password.    Once a
password has been created for that user they will not be allowed to 
enter a blank password when they change their password.    This does 
not restrict the user from changing their password.



Custom Notification
This notification method will cause the fax server to call a custom-defined command line in 
order to deliver a message.    It is up to the customer to supply a suitable executable for the 
server to call upon.    Please contact RightFAX Technical Support for more information on 
Custom Notification types.



E-Mail Notification
This notification method directs fax server messages to a user's e-mail address.    The 
optional RightFAX E-Mail Gateway is required as the server routes the messages through the 
Gateway.    The e-mail address to which a notification is sent is determined by the user's 
Routing Info field.

If a user has a notification frequency set to Periodically, then the fax server will send 
multiple e-mail messages.



Network Broadcast Notification
This notification type uses the built-in messaging system supplied by the network operating 
system.    For Netware, this is the "Send" functionality.    For LAN Server and Microsoft 
networks, this is the Messenger/WinPopup facility.

On Netware networks, DOS users need not load any extra software in order to receive 
network broadcast messages (they will appear on the 25th line [NETX] or on the 1st line 
[VLM]).    For Windows workstations, they should load the NWPOPUP utility supplied by 
Novell.    NWPOPUP is normally loaded via a 'LOAD=' or 'RUN=' command in the WIN.INI file.   
It may also be loaded by placing its icon in the Windows Startup group.    If NWPOPUP is not 
loaded, then users will not receive network broadcast messages until they exit Windows or 
until they start a DOS-Box from within Windows.    You can test a workstation's ability to 
receive broadcast messages by executing the following command from a command prompt 
on the fax server:

SEND "message" to User-ID

On LAN Server and Microsoft networks, DOS users should be running the Messenger and 
NetPopup services.    Windows users should be running the WinPopup program as well.    
Network broadcast messages may not be received by DOS and Windows workstations at all 
times depending on the applications being used on the workstations.    You can test a 
workstation's ability to receive broadcast messages by executing the following command 
from a command prompt on the fax server:

NET SEND <user-ID> "message text"



Notification Type --This determines how the user is notified by RightFAX.    There are three 
basic types of notification: 1) Network Broadcast; 2) E-Mail (requires the 
optional E-Mail Gateway; and, 3) Custom.



Password -- This field is not normally available unless the user is newly created or unless the 
Change Password button has been pressed.    If Change Password is pressed and 
no password is entered, the user's password will be erased.    You can change 
user's password without having to know the old password.



Routing Code -- Specifies the DTMF extension, DID number or Channel number that will be 
assigned    to this user.    This is the number that RightFAX will use to route a 
received fax from the fax card(s) to a specific user.

If you will be routing faxes via DTMF or DID, then the Routing Code should be 
a unique number in the range 001 to 999 (for 3-digit DTMF/DID routing) or 
0001 to 9999 (for 4-digit DTMF/DID routing).    If you will be using Channel or 
Line routing, then the Routing Code should be a unique number in the range 0
to 31.    Leading zeros are not significant.

The Routing Code should be unique.    However, RightFAX does not enforce 
uniqueness, else changing routing codes would become tedious.    If multiple 
users are assigned the same Routing Code they do not all get copies of a 
received fax -- only one will actually get the received fax.

Routing Codes in the range 0 to 31 may be subject to the Roll-Down feature, 
where the fax server will route a fax received on channel X to the nearest X-n 
routing code.    For example, if a fax was received on channel 2 (the third fax 
channel) and there was no mailbox with a routing code of 2, the fax server 
would attempt to route the fax to routing code 1, and then 0 (assuming 1 was 
not found).



Unprotected Mailbox -- Normally, only administrators can switch into a mailbox without 
supplying a password to the mailbox.    By enabling the Unprotected 
attribute, any user can switch into this mailbox without having to 
supply a password.    This is useful when setting up general, or group, 
mailboxes where security is not an issue.    This does not affect security
of phonebook entries belonging to this mailbox.



User ID -- This is a unique ID which RightFAX uses to identify users.    On Netware 3.x, LAN 
Server, and NT networks, the RightFAX User ID must match the login ID because 
the fax server uses the login ID to match print jobs from the fax queues against 
the RightFAX user database.    Thus, if the login ID did not match the RightFAX User
ID, users outbound faxes would never appear in their mailboxes.

On Netware 4.x networks, where NDS is employed, the RightFAX User ID usually 
matches the Common Name (CN) portion of the user's Distinguished Name, 
e.g. ".BOB.ACCOUNTING.ACME" would have a RightFAX User ID of "BOB".    If there
are duplicate Common Names between different Organizational Units (OU), then 
the RightFAX User ID will not match the CN of a one of users.    For example, if you
had ".BOB.ACCOUNTING.ACME" and ".BOB.SALES.ACME", then one of the BOB's 
would have a RightFAX User ID of "BOB" and the other "BOB2".    When NDS is 
employed, the RightFAX server will attempt to match print jobs against the 
Distinguished Name field of the RIghtFAX Users.    If no match is found, then the 
CN portion of the print job owner will be matched against the RightFAX User ID 
field.    In our example, this would ensure that the outbound faxes of the BOB 
users would not be confused, or mixed together.



User Name -- This is simply a descriptive field with which to identify users.    RightFAX makes 
no use of the contents of this field in normal operations.    When a user is 
automatically added by the fax server, either during import or based on a new 
print job, the User Name field will be read from the Bindery (Netware 3.x), NDS 
(Netware 4.x), or Domain Controller (LAN Server and NT).



View First Page Only -- This attribute restricts users from viewing or printing anything 
but the first page of a received fax (useful when manual routing is 
employed).    The restriction applies to the mailbox, not a user.    
Therefore, a user cannot login to RightFAX as themselves, switch into a
mailbox with the View First Page Only restriction, and be able to view 
anything but the first page of any received fax.    Faxes must be routed 
out of a restricted mailbox to another user before subsequent pages 
could be viewed or printed.



User List - This is a list of all users on a file server (Netware 3.x), an Organizational Unit 
(Netware 4.x), or a Domain (LAN Server or NT).    You may select multiple users by 
holding down the Shift or Ctrl keys while clicking on users with the mouse.



Auto Assign Routing -- Enables automatic assignment of the Routing Code field.



Import All -- Imports all users (or printers) listed in the listbox to the left.    No selections 
need be made in order to use this function.



Import Selected -- Imports only selected users (or printers) from the listbox to the left.    
This button is not active until a selection has been made.



Print Queue List - This is a list of all print queues on a file server (Netware 3.x), an 
Organizational Unit (Netware 4.x), or a Domain (LAN Server or NT).    You 
may select multiple print queues by holding down the SHIFT and/or CTRL 
keys while clicking with the mouse.



Administrator -- This is the RightFAX User ID of the group's designed Administrator.    The    
Administrator receives notification about unviewed/unprinted faxes of users 
belonging to the group who have not view or printed their faxes in a 
specified amount of time (set in the RIGHTFAX.INI    file and defaulting to 60 
minutes).

Group administrators are allowed access to the FaxAdmin program.    
However, they may only administer users who belong to the group, or 
groups, for which they are administrator (this also applies to alternate 
administrators).

Finally, group administrators (and alternate administrators) are allowed to 
switch into the fax mailbox of any users who belong to the group for which 
they are administrator without knowing users' passwords.



Alternate Admin -- This is the RightFAX User ID of group's designated Alternate 
Administrator.    The Alternate Administrator has the same rights as the 
group's Administrator.    However, the Alternate Administrator is third in line, 
behind the User and Administrator, to receive notification of 
unviewed/unprinted faxes.    When the Alternate Administrator is notified is 
controlled via the RECEIVE_NOTIFY_BRACKETS parameter in the 
RIGHTFAX.INI (the default is 3 hours).



Days to Keep Deleted Faxes -- This is the number of days for which to keep deleted fax 
records for accounting purposes.    If this field is set to 0, then 
deleted fax records will never be automatically purged by the 
fax server.    This value does not apply to Users who have the 
Auto-Purge Deleted Faxes attribute enabled.



Authorized Users -- These are the users who are allowed to place this signature on a fax 
via the <SIGNATURE:xxx> embedded code.    The Signature Owner is NOT
implicitly authorized; thus the Owner ID is usually the first Authorized ID 
to be entered.



Description -- This is a freeform text field used to identify an object.    RightFAX does not care
what goes into a Description field, it is only shown to users when they are given 
a list of objects from which to choose.



File Name -- Name of the file that represents the signature (files located in \RIGHTFAX\SIG), 
Library Document (files located in \RIGHTFAX\IMAGE) or Graphic Object (located 
in \RIGHTFAX\OBJ).    Signatures and Graphic Objects have an extension of .CFG 
(a proprietary encrypted format) and are created by Administrators using the 
Windows Fax Viewer.    Library Documents are RightFAX Group-3 formatted files 
with the extension .301, .302, etc.



Owners Userid -- This is the RightFAX User ID to whom the signature belongs.    The owner is 
NOT implicitly authorized to use the signature.



Signature Code -- This is a unique identifier for the signature.    This identifier is used in the 
<SIGNATURE:xxx> embedded fax code.    For example, to place a 
signature in a letter one might enter the following through their word 
processor:

Sincerely,
<signature:JDOE>

John Doe



Form Code -- This is a unique identifier for the form.    This identifier is used in the 
<FORMTYPE:xxx> embedded fax code.    For example, a document might 
contain the code <FORMTYPE:LETTERHEAD> to command the fax server to 
overlay the document on letterhead.    Forms can also be chosen by 
Description from the Windows Print Driver or using the FaxUtil.



Form Number -- This number is used to identify forms and to link them together via the 
Next Form ID Number field.



Image Filename -- This is the name of the file in \RIGHTFAX\PAPERS directory.



Next Form ID Number -- This is used to specify the next form that will be overlaid on top 
of this form.    In this manner you can specify compound forms of 
many layers.    If it is set to zero no additional forms will be added.    



Number of Pages -- Tells RightFAX on to how many pages this will be overlaid.    Setting this 
value to 0 indicates that the form should be overlaid into all remaining 
pages in the a fax.



Start Page -- Indicates on to which fox body page this form should be overlaid.    Fax body 
pages are numbered starting at one (1); therefore a value of 0 for Start Page is 
not valid.    It is not possible to overlay a form onto a system generated fax 
coversheet



Delete After Routing -- With this option is enabled, received faxes will be deleted from 
the RightFAX mailbox after they are successfully routed to a Network 
Directory or to an E-Mail system.    This option does not apply if the 
Routing Type is set to "RightFAX Mailbox" or "OCR".

When routing received faxes to E-Mail systems through the RightFAX E-
Mail Gateway, this option would normally be enabled, thus causing 
faxes which are successfully routed to be removed from the RightFAX 
system.    Faxes which could not be routed to e-mail, possibly because 
the e-mail system is down or because an e-mail address is incorrect, 
are not deleted from RightFAX.



Pages -- This field contains the number of pages in the Library Document.



Library Document -- Click here if you are adding a Library Document.



Graphic -- Click here if you are trying to add a Graphic Object to the library.    Graphic objects
are small logos and such that can be used in a fax with the <GRAPHIC:xxx> code. 
For example:

ACME Incorporated <GRAPHIC:LOGO>



ID Code -- A unique identifier.    This ID is used in conjunction with the <LIBDOC:xxx>, 
<LIBDOC2:xxx>, or <GRAPHIC:xxx> embedded codes.    When a user selects 
library documents via the Windows Print Driver or the FaxUtil, they are presented 
with the Library Document Description rather than the ID Code.



Printer ID -- This is a unique identifier which RightFAX uses for its own purposes.    This ID 
usually matches the network Queue ID, but this is not a requirement.    The Printer
ID should NOT contain the hyphen character (-).    If a printer object does not have
a description, then the Printer ID will be listed when users attempt to choose a 
printer from within FaxUtil, else both the Printer ID and the Description will be 
listed.



Server Name --This field indicates on which file server the print queue exists.    For Netware 
3.x networks, the name would be in the form, "SERVER", e.g. "ACMES1".    For 
Netware 4.x networks, the server name should be blank and the Queue Name
contains the NDS object name of the queue.    For LAN Server and NT 
networks, the Server Name should be in the form, "\\SERVER".



Queue Name -- The value of Queue Name differs with the Network Operating System (NOS) 
in use.    On Netware 3.x, Queue Name should contain the Bindery name of the
queue, e.g. "LASER1".    On LAN Server and NT networks, Queue Name should 
contain the Sharename of the queue.    On Netware 4.x, Queue Name should 
contain the Distinguished Name of the queue object, e.g. 
".LASER1.SALES.ACME".    Notice that the Distinguished Name must begin 
with a period.    If Queue Name does not begin with a period, RightFAX will 
attempt a Bindery print connection.



Printer Type -- Determines the printer driver used by the fax server to format faxes printed to
this printer.    Choose the one that most closely corresponds to your printer.    If
your laser printer supports both PostScript and PCL-5, choose one of the HP 
LaserJet types rather than PostScript in order to speed up printing.



Form Number (Novell Only) -- This is the form type for this printer definition.    It can be
any value from 0 through 999.    See Novell documentation for 
further information on Form Numbers within the Netware 
Printing Systems.    If in doubt, set this field to zero (0).



Default Paper Size -- Determines how the fax server will scale a fax page to fit onto the 
printable area of a laser printer.    This setting also implies what size 
paper to select.    Possible settings are as follows:

None Don't scale the image at all.    This can result in some portion of the page
being truncated.

Fit Letter Causes the fax page to be scaled to fit onto the printable area of U.S. 
Letter size paper (8.5 x 11 in.)

Fit Legal Causes the fax page to be scaled to fit onto the printable area of U.S. 
Legal size paper (8.5 x 14 in.)

Fit Letter/Legal If the fax page is 12.5 inches or less, then it will be scaled to fit onto U.S.
Letter size paper, else it will be scaled to fit onto U.S. Legal size paper.    
This setting is useful for firms receiving faxes in a mix of letter and legal 
sizes and where dual-bin laser printers are employed.    In such cases, 
the laser printer will automatically select the appropriate size paper, 
letter or legal, to correspond to the size of the fax page.

Fit A4 Causes the fax page to be scaled to fit onto the printable area of A4 size 
paper (210 x 297 mm)

Fit A4/Legal Identical to Fit Letter/Legal, except that the printer will choose between 
A4 and legal paper trays.

Note: there is always an unprintable region into which a laser printer cannot print.    RightFAX
takes this into account when scaling and fits the full fax page within the unprintable region.   
The result is a small (5%) reduction in the page image when printed on a laser printer.    
Since fax pages have no unprintable region, the scaling must occur else portions of the fax 
pages would be lost during printing.



Default Paper Source --Determines which paper tray selection command RightFAX will send 
to the printer.    If Default Paper Size is set to Fit Letter/Legal or Fit 
A4/Legal, then it is recommended that Paper Source be set to None, 
else the automatic selection of paper trays will not work as expected.



Billing Code Descriptions -- These are labels used to describe the customizable billing 
information fields (generically termed BillInfo1 and BillInfo2).    
Users will see these labels on the Fax Information dialog box from 
within FaxUtil and the Windows Print Driver.



FCS Required Fields (Received) -- By checking the boxes here you control what fields your 
users are required to supply on received faxes.    If a received 
fax does not have information in all the required fields, it is 
considered "incomplete" and it cannot be deleted.    Requiring
fields on received faxes is useful when you need to do cost 
recovery for received faxes.



FCS Required Fields (Sent) -- By checking the boxes here you control what fields your users 
are required to supply before the fax server will send a fax.    If a 
user attempts to send a fax without all the required field being 
supplied, the fax is considered "incomplete" and the fax server 
will attempt to send a message to the user alerting them to the 
incomplete fax.    Be careful when requiring any of the "From" 
fields as these may not be obvious to the users, thus causing all 
their faxes to stay "incomplete" until they figure out that they 
have not supplied the "From" information. 



Verify Billing Codes -- Causes the fax server to validate the billing information fields for every
fax against the Billing Code Table.    Enabling this option does not 
implicitly require that users enter billing codes.    If you wish to require 
your users to enter a billing code then enable the e check boxes above 
labeled    Billing Info 1/ Billing Info 2 for sent faxes.

With Verify Billing Codes enabled, the fax server will not send a fax 
unless it contains a valid set of billing fields.    Faxes with invalid billing 
fields will be set to status, "ER:Invalid Billing Code".



File Format -- The file format is used when RightFAX us routing received faxes to e-mail or to
a network directory.    This field if irrelevant when the Routing Type is set to 
RightFAX Mailbox or OCR.    Each user can have a different file format.    The 
possible formats are as follows:

PCX Single page per file with an average fax page size of 135 KBytes.    
Useful for routing received faxes to cc:Mail DOS and Macintosh 
clients as cc:Mail for DOS and Macintosh have built-in capabilities to
view PCX formatted fax pages.    Not recommended for Windows 
clients as PCX is a large format and users have to sift through 
multiple attachments when viewing multi-paged faxes.

DCX DCX is simply a consolidation of multiple PCX pages into a single 
file.    It, therefore, solves the multiple attachment problem of PCX 
files, but it maintains the large page size (average of 135 KBytes 
per page).    Microsoft Mail clients for Windows and DOS have the 
capability to view DCX formatted faxes.

TIFF-G3 TIFF is a common graphics file format.    TIFF, by itself, does not 
indicate or imply a compression scheme, hence the reason we have
the TIFF-G3 format specification.    TIFF-G3 are TIFF structured files 
where the graphics data is compressed using the Group-3 Modified 
Huffman encoding.    Group-3 compression (average of 35 KBytes 
per page) is much better on monochromatic pages (i.e. fax pages) 
when compared to PCX or DCX.    TIFF-G3 is a single file format, 
where all pages of a fax are stored in a single file (this means users 
only need deal with a single attachment within e-mail).    With the 
exception of GroupWise, none of the e-mail systems have built-in 
capabilities to view TIFF-G3 files.    For Windows mail client, you can 
use the RightFAX fax viewer by associating WFAXVIEW.EXE with 
the .TIF extension.    This will cause cc:Mail, GroupWise, and 
Microsoft Mail to launch the RightFAX viewer for viewing TIFF-G3 
attachments.

Note: if users will be receiving their faxes in e-mail and they will be
using one of the remote e-mail packages, i.e. where a modem is 
used to retrieve e-mail, then TIFF-G3 format should be used due to 
its superior compression when compared to PCX and DCX.



Routing Info -- This field is used to specify more routing information.    For example when 
using cc:Mail routing you would enter the cc:Mail e-mail address associated with
the particular user.    The Routing Info field contains different information 
depending on the value of the Routing Type selector:

Routing Type Use of Routing Info
RightFAX Mailbox If no E-Mail Gateway is installed, then this field if left empty (with the 

exceptions of OCR and Network Directory Routing Types).    If an E-Mail 
Gateway is installed, then Routing Info should contain the full e-mail 
address of the particular user.    The e-mail address entered is used to 
associate outbound e-mail messages with RightFAX users, i.e. RightFAX
may need to translate ACME/MAINPO/BOBC with the RightFAX User ID 
BOB.    Routing Info allows this translation to take place.

cc:Mail A valid cc:Mail address in one of the following formats: USER at 
POSTOFFICE

USER
#LIST at POSTOFFICE

Notes A valid Notes address in the format: USER-NAME
The user-name specified must be enough to uniquely identify the Notes
user.

Microsoft Mail A valid MS Mail address in the format: NET/PO/USER

GroupWise A valid GroupWise address in the format: DOMAIN.PO.USER
Multiple users can be specified, which is useful for routing of received 
faxes:

DOMAIN.PO.USER1,DOMAIN.PO.USER2

DOMAIN.PO.(USER1,USER2)

OCR Names the routing table to be used when OCR routing faxes though 
this mailbox.    If this field if left blank, ROUTE.TXT is assumed.    
Multiple routing tables are useful when used in conjunction with 
Line/Channel based routing.    In such a secenrio, the mailbox with 
routing code 0 might use ROUTE0.TXT and the mailbox with routing 
code 1 might use ROUTE1.TXT.    Assuming the first and second phone 
lines are not in the same hunt-group, received faxes are already broken
down into two groups prior to OCR routing.    Such a scheme can 
greatly increase the success rate of OCR routing.

Network Directory A valid path to which to store received fax images.    The field may 
contain various macros (detailed in the dialog itself) which cause the 
fax server to dynamically create subdirectories to contain the fax 
images.    Use of macros can allow you to organize images by virtue of 
the subdirectories in which they are placed.



Routing Type --Here you specify the type of routing the fax server should use to deliver 
received or forwarded faxes, i.e. RightFAX Mailbox, cc:Mail, OCR, WP 
Groupwise, MS Mail or Network Directory.    This field is strongly interrelated to
the Routing Info field.



Edit
Edits the currently selected object.    For details on editing a particular object, click on one of 
these subjects:

Edit Users
Edit Printers
Edit Signatures
Edit Library Documents
Edit Groups
Edit Forms
Edit Billing Codes



New
Creates a new object.    For details on creating a particular object, click on one of these 
subjects:

New User
New Printer
New Group
New Library
New Form
New Signature
New Billing Code



Delete
This menu item will delete the currently selected object or objects.    

See also:
Deleting Users
Deleting Printers
Deleting Forms
Deleting Signatures
Deleting Groups
Deleting Library Documents
Deleting Billing Codes



Import Data
This menu item is only enabled in some views.    See the sections below for further details:

Import Users
Import Printers
Import Billing Codes



Product Support
If you need assistance with RightFAX or any of our client software, please contact us:

RightFAX Technical Support
4400 E. Broadway Suite 312
Tucson, AZ 85711

Voice (520) 327-1357
Fax (520) 321-7456
BBS (520) 327-7456
E-mail: tech@rightfax.com

You should include all the information you can in your message, including the version of 
RightFAX, information about your network, and a description of the specific problem.    The 
more information you provide the quicker we can solve the problem.



Default User
The Default User is a special RightFAX mailbox which is used for the following purposes:

* New users inherit many of their attributes from the Default User
* Outbound e-mail messages from the RightFAX E-Mail Gateway may go through the 

Default User's mailbox so that a RightFAX mailbox need not be setup for every e-mail 
user wishing to send faxes.

* The Routing Info field for the Default User may contain special "macros" which make 
easier the setup of e-mail addresses for new users.
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Getting Started
Once RightFAX is set up and running the next step is to create or import users.    RightFAX 
provides a Default User who's settings are used as a template for imported or created users. 
To use this 'feature' set Default users settings up in FaxAdmin before Importing or creating 
users.    

You will also need to set up routing in RightFAX.    Routing controls how faxes will be 
delivered from the phone lines to the users.    There are several methods of routing that can 
be used.    See Routing Types.

The second item to be set up are the Printers.    This is done in a similar manner to the 
importing or creating of uesrs.    See Import Printers or Create Printers.



Automatic Billing Code Importing
RightFAX can automatically import billing codes from a file at a specified frequency.    To set 
this up you will need to add a line to the [WORKSRV1] section of the RIGHTFAX.INI (located in
the \RIGHTFAX\BIN directory structure):

[WORKSRV1]
AutoImportBC=15

After the above line is added, WorkServer will check for the file named CODECHG.CSV to 
appear in its directory every 15 minutes.    If such a file appears, WorkServer will attempt to 
import it into the RightFAX database.

A,billinfo1,billinfo2,description
C,billinfo1,billinfo2,description
D,billinfo1,billinfo2

A line starting with 'A' will add a billing code.    A line with 'C' will change a billing code.    A 
line with 'D' deletes the specified billing code.    All lines should terminated with a Carriage-
Return/LineFeed combination and the field values must be seperated with a comma or a tab 
(ASCII 9) character.    There cannot be any comma or tab characters within a BILLINFO1 or 
BILLINFO2 fields, though there can be in the Description data.

After the WorkServer imports the billing codes file, it will produce a file called CODECHG.LOG
which records what was and was not imported.    You can erase this file when you are done 
with it.    WorkServer will always overwrite the log file with each new import.    The original 
CODECHG.CSV file will be DELETED after importing, else the WorkServer would just find it 
again.



Routing Types
RightFAX can route all incoming faxes to specific mailboxes in four ways: with DID (Direct 
Inward Dialing), DTMF (Dual-Tone Multi-Frequency), OCR (Optical Character Recognition), or 
line (also called channel) routing.

DID routing uses a special service provided by the phone company.    A DID phone line, 
called a Trunk Line, can receive calls on many different phone numbers.    When a caller 
anywhere in the world dials any of the numbers assigned to the Trunk Line, the phone 
company sends a signal indicating an incoming call (not a ring), followed by the last 3 or 4 
digits of the phone number.    The special DID capable fax cards from Brooktrout and 
Gammalink are able to capture these digits.    The RightFAX software uses the digits to then 
route received faxes to their final destinations (users).

To use DID, buy one of these special lines, along with blocks of phone numbers, from the 
local phone company.    When ordering your DID service from the phone company, you 
should request a DID trunk line(s) with the following parameters:

Trunk Type: Loop Start
Service Type: Wink Start
Signaling: DTMF
Digit Length: 4 digits

DID Trunk Lines are not the same as individual phone lines, or analog extensions, which a 
PBX provides, even if the PBX does use DID service.    Think of the fax cards as a mini-PBX 
which operate independently of your regular phone system.

DTMF, unlike DID, uses a regular phone line with a single phone number.    The person 
sending you a fax dials this number and the call connects normally.    Before the fax 
transmission starts, the fax card prompts the caller to enter a routing code for the fax they 
are sending.    If the caller enters a valid routing code (one which is assigned to a RightFAX 
user) the fax is placed in the proper mailbox.    If the caller does not enter a code before a 
certain amount of time has elapsed, or the code entered does not correspond to a valid 
RightFAX mailbox, the fax is placed in a default mailbox.
DTMF capability is configured using the following parameters in the FAXHW.INI file: DTMF, 
Initial_Tone, Initial_Speech, Numdigits, Tonewait, and Baddigits.

OCR (Optical Character Recognition) is a separate module that converts the first page of an 
incoming fax into a text format and then scans it for pre-specified words or sequences of 
words.    Each word is associated with an individual mailbox.    If RightFAX finds any matches, 
it routes the fax to the specified mailbox.

Line/Channel Routing is simply that; if a fax arrives on a particular line, the user assigned 
to that line will receive the fax in his/her mailbox.    Assign one RightFAX mailbox to each 
incoming line.    

Manual Routing is were one or several users receive faxes using one of the above methods
and then manually routes faxes to the appropriate users.    

It is possible to use more than one routing method at a time.    For example you could have a
DID line that routes to three different people and then those indivuals would route the faxes 
to specific users within their respective departments.




